Compiling latest Gwibber on Ubuntu 11.10

Gwibber is an open source microblogging client for Linux. It brings the most popular social networking web services to your desktop and gives you the ability to control how you communicate. My favourite though was tweetdeck. But after Adobe ditched Air for Linux, Tweetdeck doesn’t look enticing anymore. I had to scout for a viable alternative . After trying lot of alternatives like choqok, hotot, I found Gwibber is the one. At least it had more feature in common with tweetdeck. Hotot has a better UI but it is still in its alpha stage..

 

I use Ubuntu 11.10 and the default version of Gwibber on it is 3.2.1. I wanted to upgrade that to the latest Gwibber version ( as of date) 3.3.1.1. It’s a pretty simple task and here it is how to do it.

 

Download the latest Gwibber source code from here https://launchpad.net/gwibber . Replace the version no. with whatever version you downloaded.

 

tar -xvf gwibber-3.3.1.1.tar.gz

 

cd gwibber-3.3.1.1

 

sudo apt-get install build-essential valac-0.14 intltool libgtk-3-dev libgtk2.0-dev libgnome-menu-dev libnotify-dev libgee-dev libsoup2.4-dev libdee-dev libjson-glib-dev gsettings-desktop-schemas-dev libgtkspell3-dev libunity-dev

 

./configure

 

make

 

make check

 

sudo make install

 

gwibber ( this will launch the newly compiled Gwibber)

 

If you had skipped the sudo apt-get step then ./configure might complain about missing packages like valac or intltool. or sometime you might end up getting 

 

configure: error: Package requirements (glib-2.0 >= 2.26

                  gobject-2.0 >= 2.26

                  gtk+-3.0 >= 3.2

                  gdk-3.0 >= 3.2

                  gio-2.0

                  gio-unix-2.0 >= 2.26

                  gee-1.0

                  libnotify >= 0.7

                  libsoup-2.4

                  pangocairo

                  dee-1.0 >= 0.5.19

                  json-glib-1.0

                  gmodule-2.0

                  gsettings-desktop-schemas) were not met:

 

No package ‘gtk+-3.0’ found

No package ‘gdk-3.0’ found

No package ‘gee-1.0’ found

No package ‘pangocairo’ found

No package ‘dee-1.0’ found

No package ‘gsettings-desktop-schemas’ found

 

If you still find yourself facing with missing package error, then identify the package as follows

 

apt-cache search | grep dev

 

find the appropriate packages from the output and add them to the sudo apt-get list above .

One Reply to “Compiling latest Gwibber on Ubuntu 11.10”

  1. Hi!

    Thanks for your step-by-step tutorial!!

    I have a problem installing valac. First I tried as is wrote here and get a error ‘valac-0.14 doesn’t exist’. After I tried installing Vala from the Vala team PPA (https://help.ubuntu.com/community/Vala) and I think I get to install the last version of valac. But now I have got contradictory messages:
    – If I do: sudo apt-get install valac-0.18 > valac-0.18 is already the most recent version
    – If: valac –version > Vala 0.12.0

    And ./configure still saying:
    checking /usr/bin/valac is at least version 0.15.0… no
    configure: error: Vala 0.15.0 not found.

    Can you help me? Any idea about what is wrong?

    Thanks!

Leave a Reply

Your email address will not be published. Required fields are marked *